<?xml version="1.0" encoding="UTF-8"?><rss version="2.0"
	xmlns:content="http://purl.org/rss/1.0/modules/content/"
	xmlns:wfw="http://wellformedweb.org/CommentAPI/"
	xmlns:dc="http://purl.org/dc/elements/1.1/"
	xmlns:atom="http://www.w3.org/2005/Atom"
	xmlns:sy="http://purl.org/rss/1.0/modules/syndication/"
	xmlns:slash="http://purl.org/rss/1.0/modules/slash/"
	>

<channel>
	<title>Tomcat 8.5.87 &#8211; SRA OSS Tech Blog</title>
	<atom:link href="https://www.sraoss.co.jp/tech-blog/tag/tomcat-8-5-87/feed/index.xml" rel="self" type="application/rss+xml" />
	<link>https://www.sraoss.co.jp/tech-blog/</link>
	<description>OSS専門の技術ブログ。PostgreSQL、Zabbixを中心に10種類以上のOSSの解説、アップデート情報、運用ヒントを提供。</description>
	<lastBuildDate>Wed, 04 Nov 2026 06:45:35 +0000</lastBuildDate>
	<language>ja</language>
	<sy:updatePeriod>
	hourly	</sy:updatePeriod>
	<sy:updateFrequency>
	1	</sy:updateFrequency>
	<generator>https://wordpress.org/?v=7.1.3</generator>

<image>
	<url>https://www.sraoss.co.jp/tech-blog/wp-content/uploads/2018/07/blog-icon-150x150.png</url>
	<title>Tomcat 8.5.87 &#8211; SRA OSS Tech Blog</title>
	<link>https://www.sraoss.co.jp/tech-blog/</link>
	<width>32</width>
	<height>32</height>
</image> 
	<item>
		<title>Tomcat 8.5.88 のリリースノート</title>
		<link>https://www.sraoss.co.jp/tech-blog/tomcat/rn-8-5-88/</link>
		
		<dc:creator><![CDATA[基盤技術グループ]]></dc:creator>
		<pubDate>Wed, 20 Dec 2023 08:33:39 +0000</pubDate>
				<category><![CDATA[Tomcat]]></category>
		<category><![CDATA[Tomcat 8.5]]></category>
		<category><![CDATA[Tomcat 8.5.87]]></category>
		<category><![CDATA[Tomcat 8.5.88]]></category>
		<category><![CDATA[アップデート]]></category>
		<guid isPermaLink="false">https://www.sraoss.co.jp/tech-blog/?p=13399</guid>

					<description><![CDATA[このドキュメントは 2023 年 4 月 19 日にリリースされた Tomcat 8.5.88のリリースノートの日本語訳です。 ダウンロードは Tomcat ダウンロードより行えます。 以下はリリースの詳細と、最新情報お ...]]></description>
										<content:encoded><![CDATA[<p>このドキュメントは 2023 年 4 月 19 日にリリースされた <a href="https://tomcat.apache.org/tomcat-8.5-doc/changelog.html#Tomcat_8.5.88_(schultz)" target="_blank" rel="noopener noreferrer">Tomcat 8.5.88のリリースノート</a>の日本語訳です。<br />
ダウンロードは <a href="https://tomcat.apache.org/download-80.cgi" target="_blank" rel="noopener noreferrer">Tomcat ダウンロード</a>より行えます。<br />
以下はリリースの詳細と、最新情報およびドキュメントを補足するその他情報について記載しています。</p>
<p><span id="more-13399"></span></p>
<h2>脆弱性修正</h2>
<p>* Apache Tomcat サービス妨害 CVE-2023-28709: CVE-2023-24998 についての修正が不充分でした。デフォルトではない HTTP コネクタ設定が、maxParameterCount がクエリ文字列パラメータを使うことで到達する可能性があり、クエリ文字列でちょうど maxParameterCount 個のパラメータが指定されるようにリクエストが投稿されるという使い方をされた場合、アップロード済みリクエストの一部がバイパスされ、サービス妨害が発生する可能性がありました。この問題が修正されました。(CVE-2023-28709)</p>
<h2>不具合修正(Catalina)</h2>
<p>* RFC 9239 が実装され、JavaScript のメディアタイプとして、application/javascript の代わりに text/javascript が使われるようになりました。(65995)</p>
<p>* Tomcat.addWebapp() メソッドの Javadoc が、docBase パラメータが相対パスであっても良いと誤って述べていた箇所が修正されました。(66527)</p>
<p>* WebResource キャッシュの追い出し順序が意図通りの LRU に修正されました。(66524)</p>
<p>* カスタム URL スキームを使用するリソースに対する、キャッシュされたリソースの取り扱いが改善されました。スキーム固有の equals() および hashcode() のアルゴリズムが存在する場合は、これらのリソースの URL に対して使用されるようになりました。これにより、いくつかの OSGi カスタム URL スキームでの潜在的な性能の問題が解決されます。OSGi カスタム URL スキームでは、設定によっては時間のかかる DNS 検索を引き起こす可能性がありました。(66541)</p>
<p>* カスタムのセッションマネージャが Web アプリケーションの一部としてデプロイされている場合、リクエストから抽出したセッション ID の検証時に ClassNotFoundExceptions が発生する問題が回避されました。</p>
<p>* StandardContext#fireRequestDestroyEvent に対し、それ自身のログメッセージが与えられました。(66543)</p>
<p>* サーバ初期化中に Random が初期化されるようになり、いくつかのプラットフォームで WebApp のコンテキストで JVM のスレッドが作成される可能性が回避されるようになりました。(66554)</p>
<h2>不具合修正(Coyote)</h2>
<p>* JSON フィルターは、RFC 8259 で規定されているような良く使われる特殊文字について個別のエスケープ処理をサポートするべきでした。このエスケープ処理が実装されました。</p>
<p>* ダイレクトバッファと共に使用された場合の GzipOutputFilter (圧縮された HTTP レスポンスで使用されます) が修正されました。(66511)</p>
<p>* 不正な HTTP レスポンスヘッダの AJP による処理が HTTP の処理に揃えられました。不正なヘッダはレスポンスから削除されるようになっています。(66512)</p>
<p>* バグ 66442 の修正で入ったリグレッションが修正されました。このリグレッションでは、いくつかの接続で、ERR_HTTP2_SERVER_REFUSED_STREAM に先行して完了する場合に、レスポンスボディのないストリームがアクティブなストリーム数を減らしていませんでした。(66530)</p>
<h2>不具合修正(Jasper)</h2>
<p>* タグファイルのパーシングが修正されました。タグファイルによってはタグディレクティブが無視される可能性がありました。(66536)</p>
<h2>不具合修正(Cluster)</h2>
<p>* FarmWarDeployer の maxValidTime 属性が、転送がキャンセルされる前に転送されたファイルの部分を受信するのと付随するリソースの後始末処理の間で許される最大時間に再定義されました。ファイル転送がキャンセルされた場合、新たな警告メッセージがログ出力されます。(66535)</p>
<h2>不具合修正(WebSocket)</h2>
<p>* WebSocket を NIO2 と共に使用する場合、書き込み中に I/O エラーが発生した場合はクローズフレームを送出するまえにタイムアウトを待つことが回避されるようになりました。(66508)</p>
<h2>不具合修正(Other)</h2>
<p>* catalina.sh の version コマンドを呼び出す際に、catalina.sh 内で $JAVA_OPTS が JVM に渡されていなかった問題が修正されました。(66507)</p>
<p>* JRE_HOME あるいは JAVA_HOME が正しく設定されていない場合のエラーメッセージが改善されました。Windows では、起動スクリプトとサービスのインストールスクリプトで、JRE_HOME と JAVA_HOME の処理が揃えられました。</p>
<h2>機能追加・改良(Catalina)</h2>
<p>* JSON フォーマットを使用するアクセスログバルブが追加されました。</p>
<p>* FORM 認証プロセスがセッションを作る場合、セッションタイムアウトを短くすることで、DoS 攻撃に対して FORM 認証プロセスが強化されました。このタイムアウトの間隔は FORM オーセンティケータの authenticationSessionTimeout 属性で設定できます。</p>
<p>* server.xml を使って maxParameterCount のデフォルト値が 10,000 から 1,000 に減らされるようになりました。server.xml に設定がない場合は、デフォルトは 10,000 のままです。</p>
<p>* Digest 認証が更新され、RFC 7616 に準拠するようになりました。これにより、新たな設定属性、アルゴリズムが、DigestAuthenticator にデフォルトを SHA-256,MD5 として追加されました。</p>
<p>* RealmBase にカスタムユーザ属性のサポートコードが追加されました。</p>
<h2>機能追加・改良(Coyote)</h2>
<p>* SocketWrapper をロックする同期ブロックがリファクタリングされ、ReentrantLock を使ってプロジェクト Loom を試してみたいユーザがサポートされるようになりました。</p>
<h2>機能追加・改良(Other)</h2>
<p>* フランス語翻訳が改善されました。</p>
<p>* 日本語翻訳が改善されました。</p>
<p>* 中国語翻訳が改善されました。</p>
<p>* MD5Encoder を使用するコードがリファクタリングされ、HexUtils.toHexString() を使用するようになりました。</p>
<p>* UnboundID が 6.0.8 に更新されました。</p>
<p>* Checkstyle が 10.9.3 に更新されました。</p>
<p>* Jacoco が 0.8.9 に更新されました。</p>
<p>詳細は以下をご覧ください。</p>
<p><a href="https://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.88" target="_blank" rel="noopener">https://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.88</a></p>
<p><a href="https://tomcat.apache.org/tomcat-8.5-doc/changelog.html#Tomcat_8.5.88_(schultz)" target="_blank" rel="noopener">https://tomcat.apache.org/tomcat-8.5-doc/changelog.html#Tomcat_8.5.88_(schultz)</a></p>
<div>
<a href="https://www.sraoss.co.jp/prod_serv/support/oss-pro-support/?utm_source=sraoss-techblog&utm_medium=referral&utm_campaign=under-article-oss" rel="noopener" style="color:initial;" target="_blank" class="no-ext"></p>
<div style="background-color:#DAEFF6; padding:20px; border-radius:8px; text-align:center;">
SRA OSSでは、各種OSS のサポートを提供しております。<br />
詳しくは<strong style="color:#2581c4;">弊社ホームページ</strong>をご覧ください。
</div>
<p></a>
</div>

]]></content:encoded>
					
		
		
			</item>
		<item>
		<title>Tomcat 8.5.87 のリリースノート</title>
		<link>https://www.sraoss.co.jp/tech-blog/tomcat/rn-8-5-87/</link>
		
		<dc:creator><![CDATA[基盤技術グループ]]></dc:creator>
		<pubDate>Wed, 20 Dec 2023 08:24:51 +0000</pubDate>
				<category><![CDATA[Tomcat]]></category>
		<category><![CDATA[Tomcat 8.5]]></category>
		<category><![CDATA[Tomcat 8.5.86]]></category>
		<category><![CDATA[Tomcat 8.5.87]]></category>
		<category><![CDATA[アップデート]]></category>
		<guid isPermaLink="false">https://www.sraoss.co.jp/tech-blog/?p=13405</guid>

					<description><![CDATA[このドキュメントは 2023 年 3 月 3 日にリリースされた Tomcat 8.5.87のリリースノートの日本語訳です。 ダウンロードは Tomcat ダウンロードより行えます。 以下はリリースの詳細と、最新情報およ ...]]></description>
										<content:encoded><![CDATA[<p>このドキュメントは 2023 年 3 月 3 日にリリースされた <a href="https://tomcat.apache.org/tomcat-8.5-doc/changelog.html#Tomcat_8.5.87_(schultz)" target="_blank" rel="noopener noreferrer">Tomcat 8.5.87のリリースノート</a>の日本語訳です。<br />
ダウンロードは <a href="https://tomcat.apache.org/download-80.cgi" target="_blank" rel="noopener noreferrer">Tomcat ダウンロード</a>より行えます。<br />
以下はリリースの詳細と、最新情報およびドキュメントを補足するその他情報について記載しています。</p>
<p><span id="more-13405"></span></p>
<h2>不具合修正(General)</h2>
<p>* メモリ割り当てがメモリフットプリントを削減するための SynchronizedStack での制限より大きくなっているバグが修正されました。</p>
<h2>不具合修正(Catalina)</h2>
<p>* バグ 66196 の修正で入ったリグレッションが修正されました。このリグレッションでは一つのリクエスト内で HTTP ヘッダやリクエスト行が破損する(一方がもう一方を上書きする)可能性がありました。(66488)</p>
<h2>不具合修正(Coyote)</h2>
<p>* NIO2 での非同期操作後のインライン状態がリストアされ、予期しない例外が時々実装によりスローされるという事実を考慮したためです。(66482)</p>
<h2>機能追加・改良(Catalina)</h2>
<p>* mod_rewrite の書き換えマップのタイプに txt: と rnd: が追加されました。</p>
<p>* CONNECT メソッドを使用した HTTP リクエストをリジェクトする際、400 より適切なレスポンスである 501 が提示されるようになりました。</p>
<h2>機能追加・改良(Coyote)</h2>
<p>* HTTP/2 の scheme 疑似ヘッダの有効性の検査が追加されました。</p>
<p>詳細は以下をご覧ください。</p>
<p><a href="https://tomcat.apache.org/tomcat-8.5-doc/changelog.html#Tomcat_8.5.87_(schultz)" target="_blank" rel="noopener">https://tomcat.apache.org/tomcat-8.5-doc/changelog.html#Tomcat_8.5.87_(schultz)</a></p>
<p>&nbsp;</p>
<div>
<a href="https://www.sraoss.co.jp/prod_serv/support/oss-pro-support/?utm_source=sraoss-techblog&utm_medium=referral&utm_campaign=under-article-oss" rel="noopener" style="color:initial;" target="_blank" class="no-ext"></p>
<div style="background-color:#DAEFF6; padding:20px; border-radius:8px; text-align:center;">
SRA OSSでは、各種OSS のサポートを提供しております。<br />
詳しくは<strong style="color:#2581c4;">弊社ホームページ</strong>をご覧ください。
</div>
<p></a>
</div>

]]></content:encoded>
					
		
		
			</item>
	</channel>
</rss>
